(Solved) After upgrade (5.43.2) webserver is not starting

Everything about external control, apps, VNC, etc goes here.

Moderators: marcelr, TerrorSource, Toonz, TheHogNL

(Solved) After upgrade (5.43.2) webserver is not starting

Postby bassie001 » Thu May 27, 2021 9:57 pm

Hi,

After upgrading my (rooted) toon to version 5.43.2 lighttpd is not starting and remote (mobile) access is not working anymore.

After some digging and manually starting the lighttpd:

Code: Select all
/usr/sbin/lighttpd -D -m /usr/lib/lighttpd -f /qmf/etc/lighttpd/lighttpd.conf
2021-05-27 21:14:56: (/home/jenkins/workspace/oe/build-qmf-snapshot/oe/build/tmp/work/cortexa9hf-vfp-neon-angelica-linux-gnueabi/lighttpd/1.4.35-r6/lighttpd-1.4.35/src/configfile.c.957) source: /qmf/etc/lighttpd/lighttpd.conf line: 54 pos: 2 parser failed somehow near here: }


seems like the /qmf/etc/lighttpd/lighttpd.conf is not correct anymore:

Code: Select all
/qmf/etc/lighttpd# diff lighttpd.conf lighttpd.conf.lastversion
--- lighttpd.conf
+++ lighttpd.conf.lastversion
@@ -46,6 +46,14 @@
server.document-root = "/qmf/www"
}

+$HTTP["remoteip"] !~ "localhost|127.0.0.1|192.168.2.139" {
+    $HTTP["url"] =~ "^/happ_thermstat/" {
+      url.access-deny = ( #"" )
+  ""              =>      "application/json",
+    }
+ }
+
+
## where to send error-messages to
server.errorlog             = "/tmp/lighttpd_error.log"

@@ -111,7 +119,8 @@
   ".tbz"          =>      "application/x-bzip-compressed-tar",
   ".tar.bz2"      =>      "application/x-bzip-compressed-tar",
   # default mime type
-  ""              =>      "application/octet-stream",
+  #""              =>      "application/octet-stream",
+  ""              =>      "application/json",
  )

# Use the "Content-Type" extended attribute to obtain mime type if possible


Ps. lastversion is the incorrect latest version.

After replacing the old version everything started correctly.
bassie001
Starting Member
Starting Member
 
Posts: 3
Joined: February 2021

Re: (Solved) After upgrade (5.43.2) webserver is not starting

Postby TheHogNL » Fri May 28, 2021 8:25 am

That is a patch from update script went wrong due to some modification on the older ligghtpd.conf by yourself (adding the url.accessdeny)
Member of the Toon Software Collective
User avatar
TheHogNL
Forum Moderator
Forum Moderator
 
Posts: 1904
Joined: August 2017


Return to Toon external control

Who is online

Users browsing this forum: No registered users and 1 guest