Page 1 of 1

Running otmonitor on orange pi 2 plus

PostPosted: Sun Dec 03, 2017 6:49 pm
by oipmok
i'm trying to run otmonitor - Linux-armhf on armbian on orange pi 2 plus, doesn't work, i can't find the tclkit for armbian and built my self . Someone ran otmonitor on armbian and orangepi ?

logs:

pi@orangepiplus:~/otgw$ ldd otmonitor-ahf
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6f08000)
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xb6e90000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6e6c000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6d80000)
/lib/ld-linux.so.3 => /lib/ld-linux-armhf.so.3 (0xb6f1b000)
pi@orangepiplus:~/otgw$ uname -a
Linux orangepiplus 3.4.113-sun8i #18 SMP PREEMPT Thu Jun 15 02:16:06 CEST 2017 armv7l armv7l armv7l GNU/Linux
pi@orangepiplus:~/otgw$ ./otmonitor
bash: ./otmonitor: No such file or directory
pi@orangepiplus:~/otgw$


Sorry for my English

Re: Running otmonitor on orange pi 2 plus

PostPosted: Sun Dec 03, 2017 9:12 pm
by hvxl
I moved your post to a new topic, because it really had no relation to the "Opentherm Monitor - Error running from sources" topic you originally posted in.

First of all, your output shows that your executable is called otmonitor-ahf. So then it's no surprise that you cant run it as ./otmonitor. Try ./otmonitor-ahf.

On an orange pi it may be necessary to create a symbolic link (as root):
ln -s /lib/ld-linux-armhf.so.3 /lib/ld-linux.so.3

Re: Running otmonitor on orange pi 2 plus

PostPosted: Sun Dec 03, 2017 9:49 pm
by oipmok
I did symbolic link and now :

pi@orangepiplus:~/otgw$ ./otmonitor-ahf
couldn't load file "/tmp/tcl_d5kmjW": libXss.so.1: cannot open shared object file: No such file or directory
while executing
"load /home/pi/otgw/otmonitor-ahf/lib/tk8.6/libtk8.6.so Tk"
("package ifneeded Tk 8.6.4" script)
invoked from within
"package require Tk"
("try" body line 2)
(file "/home/pi/otgw/otmonitor-ahf/gui.tcl" line 2)
invoked from within
"source /home/pi/otgw/otmonitor-ahf/gui.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list source [file join /home/pi/otgw/otmonitor-ahf $file]]"
(procedure "include" line 2)
invoked from within
"include gui.tcl"
(file "/home/pi/otgw/otmonitor-ahf/otmonitor.tcl" line 1712)
invoked from within
"source /home/pi/otgw/otmonitor-ahf/otmonitor.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0 [list source [file join /home/pi/otgw/otmonitor-ahf $file]]"
(procedure "include" line 2)
invoked from within
"include otmonitor.tcl"
(file "/home/pi/otgw/otmonitor-ahf/main.tcl" line 13)
pi@orangepiplus:~/otgw$

Re: Running otmonitor on orange pi 2 plus

PostPosted: Mon Dec 04, 2017 8:52 pm
by hvxl
It seems your system is missing the libxss1 package (apt-get install libxss1). Do you actually intend to run otmonitor as a GUI program? Otherwise you may want to run it as:
    ./otmonitor-ahf --daemon

Re: Running otmonitor on orange pi 2 plus

PostPosted: Tue Dec 05, 2017 8:14 pm
by oipmok
YEs it works !

sudo ./otmonitor-ahf -w 8181 --daemon -f otmonitor.conf

Thank You !!!

I use Tcp connections via USR-TCP232-302 on my otgw, how to modify otmonitor.conf file to tcp connection:

connection {
......
}

i can't find examples

Re: Running otmonitor on orange pi 2 plus

PostPosted: Wed Dec 06, 2017 11:20 pm
by hvxl
Normally it's easiest to run otmonitor as a GUI and configure the connection as you want it. Then you can use the configuration file produced that way for non-GUI mode. For a TCP connection you would get something like:
Code: Select all
connection {
  type tcp
  port 23
  host 192.168.5.7
  enable true
}

Re: Running otmonitor on orange pi 2 plus

PostPosted: Wed Dec 06, 2017 11:47 pm
by oipmok
Works !

Thank You