Page 1 of 1

Timeout when sending commands

PostPosted: Wed Jan 30, 2019 9:15 am
by jeroentje
Hi All,

I have the OTG running for a few years now, but recently I ran into an issue, which I don't seem to get fixed.
I have been using the http commands in order to set the outside temperature OT=value and setpoint temp TT=value. This has always worked flawless, but I noticed that the outside temperature wasn't updated anymore. Untill then I also found out that I was unable to set the setpoint temperature anymore. While doing some troubleshooting I noticed the following. I am sending the command http://localhost:port/command?OT=5. Takes longer than normal, and then the output shows "timeout".
I also noticed that I am unable to fetch other things like version. They all timeout. It looks as if the gateway isn't connected to my raspberry pi, However I am seeing messages and burner, return water temp and so on.
You can see the commands being sent to the websocket, because they are being printed in the message log, but the gateway doesn't do anything with it.
I also cant switch between gateway and monitor operation.

The gateway is connected via usb(serial) to my raspberry pi

lsof /dev/ttyUSB0
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
otmonitor 3557 pi 11u CHR 188,0 0t0 6787 /dev/ttyUSB0

ls -al /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 jan 30 09:35 /dev/ttyUSB0

I have recently updated to otmonitor version 4.3, but also when I switch back to the old version I am getting the same results. Does anyone have a clue on how to fix this? Thanks alot!

Re: Timeout when sending commands

PostPosted: Wed Jan 30, 2019 1:50 pm
by hvxl
It seems you only have one-way communication, from the OTGW to your RPi, not in the other direction. This could be a problem with the OTGW, the connections, or the USB device.

I would first try to power cycle the OTGW. If the problem remains, check the connection of the USB device to the OTGW, especially the transmit wire of the USB device. Next, try a different USB-serial device. Then replace the MAX232, if you use that. If all of that doesn't fix the problem, the I/O pin of the PIC is probably blown. That would mean you will have to replace the PIC to get it working again.

Re: Timeout when sending commands

PostPosted: Wed Jan 30, 2019 3:13 pm
by jeroentje
Thanks! I will investigate these things. It worked before so it seems to be a mystery.

Re: Timeout when sending commands

PostPosted: Thu Jan 31, 2019 10:28 am
by jeroentje
I cycled the power on the OTGW and that fixed the issue. Thanks!

Re: Timeout when sending commands

PostPosted: Mon Oct 07, 2019 7:29 pm
by JeroenSt
I have this issue also very often when the connected esp has been resetted.

I think the serial data on startup of the esp messes up the serial receive buffer of the opentherm firmware causing the otgw to become deaf for serial commands.

My assembler knowledge is not enough to debug this...